Themes upgraded for xenforo 2.2.0

Ehren

Administrator
Staff member
Customer
Messages
3,489
Website
www.xenfocus.com
Hi everyone,

I'm happy to announce that all xenfocus themes have been updated and released for Xenforo 2.2.0!

As always, the upgrades are available for existing subscribers in the Client Area.

The 2.2.x themes are bundled using the new "Export as archive" feature. This feature compresses the entire theme (the xml file and all assets) into a single zip file which can be uploaded into your ACP. No more FTP necessary!

If you would like to use the "2.1" method (using FTP to manually upload files), simply extract the zip file on your computer and you'll be able to access the assets and xml file like normal.

If anyone has questions, feel free to post them below - otherwise enjoy, and best of luck with xenforo 2.2.0! :)
 

xXArmestakkerXx

Member
Customer
Messages
36
Alright Thanks a lot!
Did it update when i updated xenforo or do i need a clean installation?
I dont understand it to be fair. I never updated Xenforo before.
 

Ehren

Administrator
Staff member
Customer
Messages
3,489
Website
www.xenfocus.com
Alright Thanks a lot!
Did it update when i updated xenforo or do i need a clean installation?
I dont understand it to be fair. I never updated Xenforo before.
You'll need to upload the 2.2 theme once you've upgraded xenforo. Use the "Overwrite style" feature when importing your theme to upgrade your existing 2.1 theme.
 

STOG

Member
Customer
Messages
53
Website
www.swifttrawlerowners-forum.com
Thanks Adrian - using the auto merge workd on the two templates that I had modified and all is working well.

However, I have not modified the PAGE_CONTAINER and when I click on the "merge" option it shows many highlighted bits of code that mean nothing to me and have not been modified by me....despite the dates showing for "last edited".... can this be caused by some other add-on?

Any ideas ?....

1601716323752.png
 
Last edited:

Ehren

Administrator
Staff member
Customer
Messages
3,489
Website
www.xenfocus.com
I'd likely need to see what code changes it's prompting you to do. I'm unsure why the PAGE_CONTAINER file would be coming up in the Merge area if it hasn't been modified on your end.
 

STOG

Member
Customer
Messages
53
Website
www.swifttrawlerowners-forum.com
Hi Ehren - I have now resolved all the errors I was experiencing.

They were all probably caused by my ignorance and lack of knowledge.

However just in case these crop up for other inexperienced users I thought I would write a short account of what I did.

1. Upgraded XENFORO (in this case to v 2.2) using the automatic upgrade feature of the admin cp see https://xenforo.com/xf2-docs/manual/install-upgrade/#upgrading-in-xenforo-21

This resulted in the message "Outdated Templates" see the example below:

1601826996331.png

2. I upgraded the XENFOCUS theme "Illuminate" to the new version compatible with Xenforo 2.2

a) By downloading the appropriate zip file - illuminate_xenfocus.zip
b) But, then unzipping this file to get style-illuminate.zip on my local drive.
c) Using the import a style feature on the styles menu

In my case I have a small number of mods to the XenFocus theme templates. When I made these mods to the XENFOCUS theme "Illuminate" I created a child of the theme called "Light Modern". This is what my forum members use and it is where my mods are. So I not only have a style called "Illuminate" but I also have a child of that style called "Light Modern"

This is why I got the "Outdated Templates" message.

3. To sort out the "Outdated Templates" issue I then:

a) Used the "automatically merge" option that shows next to the error message. This removed some of the template errors but not all.

b) I then went to the styles menu

c) I selected my child theme "Light Modern" and changed which theme it was a child of. In other words made sure it was a child of the newly installed "Illuminate" theme not the pre-existing old "Illuminate" theme - you can check you have the right one by comparing the "asset locations"

1601827942770.png

When I changed which theme it was a child of it took a good 10 minutes or so to implement this switch....

e) I then deleted the pre-existing old theme "Illuminate"

At this point all the error messages disappeared and everything seems to be ok.

I hope the above makes sense and is of use to others.

All the best
 

Ehren

Administrator
Staff member
Customer
Messages
3,489
Website
www.xenfocus.com
Hi @JOGARA

It seems as though your license expired back in February. You'll need to renew if you want to download the 2.2 theme and access the Customer area (which includes that tutorial).

Hopefully that helps to clarify! :)
 

IamBidyuT

Member
Customer
Messages
41
Hi @JOGARA

It seems as though your license expired back in February. You'll need to renew if you want to download the 2.2 theme and access the Customer area (which includes that tutorial).

Hopefully that helps to clarify! :)
Hi,
Though not having any issue, just curious to know if any update coming for XF 2.2.1 ? :)
 
Top